Windows 10 + SSD + HDD = problemas de arranque

Este debate contiene 13 respuestas, tiene 4 mensajes y lo actualizó  bakanly hace 1 año, 3 meses.

Viendo 10 publicaciones - del 1 al 10 (de un total de 14)
  • Autor
    Publicaciones
  • #192033


    Nacho
    Participante

    De vuelta con problemas de disco duro.

    Antecedentes:
    Cuando tuve que enterrar mi anterior disco duro HDD decidí comprar un disco SSD para utilizarlo para la instalación y arranque, y mantener otro disco duro HDD Toshiba 2TB para almacén de archivos.

    Instalé el SSD en junio. Además decidí actualizar mi SO Win 8.1 original al nuevo Win 10.
    Desde entonces estoy contento en general y no he tenido problemas de funcionamiento hasta hace un par de días.

    Problemática:
    Intenté arrancar el ordenador el jueves por la noche y me dio un fallo de arranque muy feo: 0xc00000f o algo parecido. Investigué y pensé que iba a tener que formatear, o peor, devolver el SSD incluso.
    Conseguí hacerme con una memoria USB como disco de arranque. Después de intentar varias cosas (restaurar, reparación del inicio, etc) desconecté el disco de 2TB y conseguí volver a arrancar el PC usando el comando bootrec. Volví a poner todo como estaba y ya arrancaba de nuevo todo bien.

    Ayer, viernes, volví a arrancar mi pc normalmente, sin problemas.

    Hoy me ha vuelto a pasar. He hecho varios intentos con el bootrec y no arrancaba de nuevo, hasta que he vuelto a desconectar el disco de 2TB y me ha vuelto a arrancar bien. Pero ahora tengo que volver a conectar el disco de 2TB y volver a probar.

    Como dato diré también que al pulsar F8 para seleccionar la unidad de arranque, teniendo los 2 discos, el lector de DVD y el USB como unidades posibles para el arranque, en algunas ocasiones no aparecía el SSD.

    Sospecho que, por algún motivo que desconozco, el arranque se raya e intenta iniciar desde el disco duro de 2TB, el cual nunca ha tenido una instalación de Windows. Así que tampoco tiene archivos de arranque. ¿Podría ser que alguno esté también agonizando? ¿Se os ocurre como resolver esto?

  • #192035


    campbell
    Participante

    Pff, no sé

    Si dices que a veces en el menú (que entiendo que sería el menú Bios entre comillas) no aparece ese disco duro, parece como que en ocasiones la placa base no detectara ese disco duro.

    A saber si es un fallo de eso o un fallo del propio disco… yo qué sé xD

  • #192042


    Nacho
    Participante

    Pff, no sé

    Si dices que a veces en el menú (que entiendo que sería el menú Bios entre comillas) no aparece ese disco duro, parece como que en ocasiones la placa base no detectara ese disco duro.

    A saber si es un fallo de eso o un fallo del propio disco… yo qué sé xD

    Acabo de reconectar el disco de 2TB y he iniciado con normalidad de nuevo.

    Entonces, ¿podría ser un problema del disco SSD o del puerto donde está conectado a la placa?
    La placa es una Asus P8H77-M, tiene 2 puertos SATA a 6GB/s, donde están los discos duros, y 4 puertos SATA a 3GB/s, donde solo está el DVD.
    ¿Se os ocurre alguna forma para diferenciar quien tiene el problema?

    ¿Puede ser que, si no detecta el SSD (1 vez), el resto de veces que intenta arrancar se vaya directamente al otro disco duro, y por eso nunca consigo arrancar?

    Edito: El SSD traía un software que tengo instalado, que indica que el AHCI mode está desactivado. ¿Eso ayudaría? Mientras tanto voy a actualizar los drivers de la placa.

  • #192045


    campbell
    Participante

    Hombre, con unidades Sata la teoría es que tienen que funcionar con el modo Ahci.

    Actívalo a ver como va

  • #192058


    Nacho
    Participante

    He actualizado los drivers de la placa (salvo los de la BIOS), he activado el AHCI y de momento va bien la cosa. Veremos a ver a lo largo de esta semana…

    ¿Debería actualizar la BIOS?

  • #192060


    campbell
    Participante

    Hay que ir con cuidado con toquinear la BIOS.

    Si ya no vuelve a fallarte más yo lo dejaría así.

  • #192115


    bakanly
    Participante

    Si te vuelve a fallar, yo actualizará la BIOS. Yo creo que debe de haber algún problema de compatibilidad entre la controladora de los discos que viene en la placa y el disco duro.

    Pero como dice Campbell, si no te vuelve a fallar no tocaría nada de la BIOS. No es que sea complicado, pero si la actualización no esté bien del todo, podría petarte por todos los lados.

    Si eres feo escucha Death Metal.

  • #192126


    campbell
    Participante

    Exacto. La BIOS es el software integrado en la placa que es lo primero que se ejecuta al encender el PC. Si se fastidia eso tendrías un contundente pisapapeles (o bien tener que poner una placa base nueva xD)

  • #192197


    Agus
    Participante

    Por cosas así, en cuanto me pille una SSD sacaré el disco duro HDD y lo convertiré en disco duro externo con una carcasa USB 3.0 de 10 euskos

  • #192206


    Nacho
    Participante

    Actualizar BIOS no es nuevo para mi, ya que en mi anterior PC tuve que hacerlo para poder instalar un microprocesador algunos años mas moderno que la placa, ya que la versión de BIOS que tenia instalada no lo admitía. Eso sí, en Gigabyte el método me pareció más sencillo.

    Si no queda más remedio, tiraré por esa via. Pero sí, si la cosa se queda tranquila, prefiero no tocar nada.

Viendo 10 publicaciones - del 1 al 10 (de un total de 14)

Debes estar registrado para responder a este debate.